Praca Miesiąca - guests

Memento Mori
Praca Miesiąca Styczeń-Kwiecień 2020
mrys

Pokaż wiadomości

Ta sekcja pozwala Ci zobaczyć wszystkie wiadomości wysłane przez tego użytkownika. Zwróć uwagę, że możesz widzieć tylko wiadomości wysłane w działach do których masz aktualnie dostęp.


Wiadomości - Kubik

Strony: 1 2 3
1
1. W swoich pracach też mam ten problem.
2. Nie mogę pobrać pliku Twojego.

Racja, zły link. Już podmieniłem ;)

P.S.
O, fajnie, teraz Blender się wysypał podczas renderu..... Nowe funkcjonalności są fajne, ale chyba wolałbym aby najpierw dopracowywali istniejące.....

2
Cześć, mam duże problemy z symulacjami w Blenderze 2.92 (testowałem też na 2.91 - to samo). Blender nieoczekiwanie kończy pracę podczas symulacji, najczęściej podczas wypalania "Noise".

Tutaj jest link do uproszczonej wersji mojego projektu:
https://drive.google.com/file/d/1ETT5jyZjL1gvIAzb_ZKdk9R8cOrlCEV9/view?usp=sharing

To na pewno jest błąd w programie, ale mam prośbę aby ktoś potwierdził czy ma tak samo. Miło by było jeśli ktoś będzie w stanie przetestować też mój projekt. Problem występuje również na mniejszych rozdzielczościach domeny, więc spokojnie można obniżyć. Ja testowałem od 128 do 2048.
Problem jest zgłoszony tutaj przez kogoś, ja się dopisałem w komentarzu: https://developer.blender.org/T86053#1127033
Jeżeli ktoś ma podobnie to prosiłbym o dopisanie czegoś od siebie tam, może dzięki temu coś się ruszy w temacie, bo jak narazie to odd 2 tygodni nikt z deweloperów/testerów tam chyba nie spojrzał....

3
Mam problem z połączeniem 2 proceduralnych materiałów które stworzyłem za pomocą node'ów i wykorzystaniem adaptive subdivisions.  Pierwszy z nich tworzy pustynne wydmy, drugi ma przypominać suchą równinę i chcę je połączyć za pomocą gradient texture i color ramp, aby wyglądało to jak koryto wyschniętej rzeki biegnącej prze pustynię. Udało mi się to zrobić, ale napotkałem problem z którym nie wiem co zrobić i mnie trochę zaskoczył. Scena wygląda tak:
https://postimg.cc/9DtWTZpF
Problem o którym mówię to te schody, "banding" na przejściu z jednego materiału na drugi powodowany przez node "color ramp". Wygląda to jakby ten gradient był 8-bitowy (a przynajmniej takie artefakty widziałem gdy korzystałem z 8-bitowych displacement maps), ale nie wiem jak to możliwe skoro color ramp tak na prawdę tworzy matematyczne przejście z jednego koloru do drugiego. Taki efekt jest niezależnie od wybranej metody interpolacji, czasem bardziej lub mniej widoczny.
Wiecie o co może chodzić? Jak to obejść? Jedyne co mi przychodzi do głowy to bug lub "coś nie włączone gdzieś". Dziwi mnie to, bo często korzystałem z tej techniki łączenia materiałów i do tej pory nie miałem problemów, choć to akurat pierwsza tego typu scena. Może zrobię ten gradient w Photoshopie i zaimportuję jako teksturę, ale nie o to chodziło. Materiał miał być w 100% proceduralny.

4
Czy ktoś wie co się stało z kołem kolorów w Blenderze 2.92? Wyświetla mi dziwne wartości, które zachowują się jakby nie były liniowe. Dla porównania z 2.83:
https://ibb.co/M5YXBLX

5
W 2.90:
Cytuj
Updated gravity: Matches world gravity now (fluid buoyancy behaves differently compared to 2.8x releases).
Może to jest jakaś wskazówka....ale przydałaby się jakaś informacja jak przełożyć stare na nowe, bo eksperymentowanie na ślepo z czekaniem godzinę na rezultat to tak średnio fajna opcja.

6
Cześć!
Zacząłem pracę nad eksplozją w Blenderze 2.82 i wróciłem do projektu po kilku miesiącach. Najpierw otworzyłem go w Blenderze 2.91, dzisiaj w 2.92 i w obu przypadkach jest ten sam problem. Symulacja wygląda zupełnie inaczej. Jedyne co robię to otwieram ten sam projekt w oryginalnym 2.82 i teraz w 2.92, wypalam ją w obu i porównuję te same klatki. Nie wiem z czego to może wynikać.
Eksplozja jest tworzona za pomocą cząsteczek, w pierwszej klatce ustawiam ich rozmiar w symulacji na 4, po kilku klatkach schodzę do 1. Tutaj wygląda to tak jakby te rozmiary cząstek były inne (mniejsze w 2.92) na dodatek dym i ogień zachowują się zupełnie inaczej (w 2.92 ogień jest widoczny dużo dłużej, jest go więcej-inne zachowanie parametru Dissolve?).

Tutaj macie przykład tej samej klatki w 2.82:
https://imgur.com/dsXVs64

I 2.92:
https://imgur.com/AENP4mv

Czy ktoś wie o jakichś dużych zmianach w Mantaflow od czasu 2.82/83? Trochę to irytujące, bo chciałem wykorzystać w projekcie niektóre nowości z 2.92, ale symulacja wygląda dużo gorzej niż wcześniej. Dochodzenie ręcznie do tego jaki parametr może się inaczej zachowywać jest bardzo czasochłonne, zwłaszcza jak na projekt "po godzinach" na który dziennie znajduję z godzinę wolnego czasu......

7
Prace ukończone (3D) / Odp: Republic YP-43 Lancer
« dnia: 10.06.2020 11:28:17 »
Dla mnie bomba ;) Ładnie uchwycona dynamika.

8
Oświetlenie i rendering / Problem z Principled Volume w 2.83
« dnia: 07.06.2020 14:39:40 »
Cześć!
Dzisiaj postanowiłem pobrać nowego Blendera, czyli wersję 2.83. Odpaliłem ostatnią scenę nad jaką pracowałem (Tytan, księżyc Saturna) i od razu zobaczyłem, że coś jest nie tak....Niezbyt miłe.
Atmosferę robię z wykorzystaniem shadera Principled Volume i nieco matematyki do obliczania jego gęstości. W załączniku render z Blendera 2.82a i 2.83. Ustawienia dokładnie takie samo, bo scena po prostu otwarta, bez najmniejszych nawet modyfikacji. Czy wiecie o co może chodzić? Coś zmieniane było w tym shaderze? Trochę mnie to zdenerwowało, bo mam kilka podobnych scen...

EDIT:
Udało mi się dojść do tego co może być nie tak. Nigdzie nie widziałem informacji o tej zmianie, ale ją znalazłem.  W zakładce "Render Properties", w sekcji Volumes rozbito parametr "Step size" na dwa: "Step rate Render" i "Viewport" (całkiem dobry pomysł) i przy otwieraniu projektu stworzonego w starszej wersji, wartość ta nie jest importowana i ustawione są domyślne parametry. To powodowało dlaczego render wyglądał zupełnie inaczej niż wcześniej, gdy ten parametr ustawiłem na znacznie mniejszy niż domyślnie.

9
Animacja i symulacje / Odp: Problem ze znikającym ogniem
« dnia: 24.04.2020 23:25:04 »
Dzięki, pomysł z zapalnikiem całkiem ciekawy ;)
Pokombinowałem jeszcze trochę i udało mi się osiągnąć dobry efekt wyłączając Initial Velocity i zastępując je wiatrem: https://www.youtube.com/watch?v=4476TIXvizI&feature=youtu.be. Teraz pozostaje to dopracować, ale działa mniej więcej tak jak chciałem.

11
Animacja i symulacje / Odp: Problem ze znikającym ogniem
« dnia: 21.04.2020 10:29:45 »
Tak, zapomniałem napisać, że pracuję na 2.82a. Reaction Speed mam tutaj już ustawione na 0.1, w ustawieniach Flow zachowanie również na Inflow.
Poeksperymentowałem teraz z tym parametrem Fuel o którym piszesz i choć nieco potrafi on spowolnić ten efekt rozwiewania ognia to jednak niewiele to pomaga :/

Tutaj Fuel ustawiłem na maksymalna wartość 10, a Initial Velocity pozostawiłem na 5:
https://www.youtube.com/watch?v=dRXIrHqq7lQ&feature=youtu.be

12
Animacja i symulacje / Problem ze znikającym ogniem
« dnia: 20.04.2020 23:34:12 »
Cześć, pracuję nad symulacją ognia z silnika rakietowego i napotkałem pewien problem. Chcę aby płomień miał dużą prędkość, charakterystyczną dla silników tego typu, więc zwiększyłem parametr initial velocity normal na 5. Problem w tym, że im ta prędkość jest większa tym ogień szybciej....znika. Wygląda jakby ogień był wyemitowany tylko na początku i "rozdmuchany": https://imgur.com/yjJg7mO
Dlaczego tak się dzieje? Jak mogę emitować ten ogień z obiektu cały czas, ale ze zwiększoną prędkością?

13
Cześć! Próbuję zrobić efekt zorzy polarnej wokół biegunów kuli ziemskiej i mam jeden problem. Udało mi się to zrobić całkiem nieźle, ale chciałbym poprawić jedną rzecz: https://imgur.com/bqqY0Gz. Stworzyłem jeden gradient sferyczny do kontrolowania gęstości objętości zorzy: https://imgur.com/NnaWhYj, następnie za pomocą Color Ramp wygenerowałem kształt tej zorzy na powierzchni kuli: https://imgur.com/ZljrPKH i połączyłem ze sobą dzięki czemu uzyskałem taki efekt: https://imgur.com/bubWHUh. Jest nieźle, ale nie podoba mi się to, że te okręgi mają cały czas taką samą średnicę, nie rozchodzą się od środka kuli.

Co muszę zrobić aby te kręgi rozchodziły się od środka kuli (im bliżej powierzchni, tym szersze), a nie miały stałą szerokość na całej osi Z?
Mój materiał wygląda w ten sposób: https://imgur.com/NM3ei1J.
Od góry: gradient koloru, gradient gęstości, kształt okręgów.

14
Ok, mój błąd. Przełączając się z renderingu CPU + GPU na OptiX nie zwiększyłem rozmiaru tile'a. Na 256x256 jest zauważalny wzrost wydajności w większości projektów, choć mam wrażenie, że z wolumetryką sobie kiepsko radzi. Tutaj wzrost jest rzędu kilku procent.

15
Po zakupie karty Nvidia RTX 2080 Ti długo czekałem na wykorzystanie nowej technologii do renderingu w Cycles. W końcu wyszedł stabilny Blender 2.81 ze wsparciem dla OptiX'a. Pobrałem go, zaktualizowałem sterownik karty i testuję. Niestety, wbrew zapowiedziom u mnie przyspieszenia renderu nie widać, a chwilami jest nawet wolniej... Testowałem narazie na 2 projektach: wizualizacja pokoju i Ziemi z orbity. W tym pierwszym przypadku rezultat jest podobny jak wcześniej na CUDA, w drugim z niecałych 10 min render wydłużył się do pawie 13.
Ktoś już testował 2.81 pod tym kątem? To topowa karta, ludzie chwalą się sporymi poprawami, a u mnie jest gorzej niż było...

Załączony render w Blenderze 2.81 generował się z wykorzystaniem samego GPU a takich czasach:
CUDA: 09:21.44
OptiX: 12:14.45


Na początku myślałem, że to ze względu na sterownik z serii Game Ready, ale po zmianie na Studio jest podobnie.

Strony: 1 2 3

* Zaloguj




* Losowy obrazek

biblioteka

Wyświetleń: 789
Autor: Kusociński
w: biblioteka