Praca Miesiąca - guests

Memento Mori
Praca Miesiąca Styczeń-Kwiecień 2020
mrys

Autor Wątek: problem oświetlenie i normal map.  (Przeczytany 564 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline sir_Gio

  • Noob
  • Wiadomości: 3
    • Zobacz profil
    • Osiągnięcia
problem oświetlenie i normal map.
« dnia: 08.03.2021 19:56:48 »
Mam zaprojektowaną klatkę schodową. Jest tam kilka świateł punktowych. Na stopniach i spocznikach (na wszystkich płaszczyznach położona jest textura betonu :  color map + normal map. W Eevee wszystko jest Ok. Ale w Cycles światła na tych płaszczyznach są z jakiegoś powodu zależne od kierunku patrzenia. Jak patrzę na wprost lub w dół, wszystko jest OK. Jak obniżam punkt widzenia i zaczynam patrzeć do góry,  to  niektóre płaszczyzny robią się ciemne, a przy dużych kątach patrzenia czarne. "Wina" jest po stronie normal map. Jak odłącze noda "normal map" to wszystko wraca do normy,  tyle że nie mam efektu nierówności betony. Sytuacja też zmienia się w zależności od ustawień w nodzie "normal maps" : Space (tu przy zmianie przestrzeni czarne pola pojawiają się w innych miejscach) i Strength (tu zaciemnienie znika dopiero przy wartości 0). Mam inne obiekty (ściany z tynkiem) dla których nody i  mapy są skonstruowane identycznie i tam ten problem nie występuje.  Hmm ... jak to naprawić ? 
 

Offline Piotr

Odp: problem oświetlenie i normal map.
« Odpowiedź #1 dnia: 09.03.2021 14:19:52 »
Chyba w nodzie Normal Map powinieneś zmienić World Space na Tangent Space.
 

Offline EasyBlendr

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Odp: problem oświetlenie i normal map.
« Odpowiedź #2 dnia: 24.03.2021 01:24:03 »
za duża wartość strength no i  tangent może trzeba, ale nie koniecznie, bo to zależy od mapy, od tego jak była wypalana. Ogólnie nie bardzo lubię normal map bo często dziwne efekty wychodzą, lepiej dawać bamp dla małych nierówności i displacement.
 

 

Problem ze swiatlem point light przy jednoczesnym uzywaniu HDRI

Zaczęty przez KrzysztofJDział Oświetlenie i rendering

Odpowiedzi: 6
Wyświetleń: 5121
Ostatnia wiadomość 24.04.2018 01:28:39
wysłana przez KrzysztofJ
Texture Coordinate Sterowanie przez Armature Pose Mode Problem

Zaczęty przez alien1983Dział Modelowanie

Odpowiedzi: 0
Wyświetleń: 2223
Ostatnia wiadomość 09.04.2020 19:10:17
wysłana przez alien1983
Sterownik AMD przestał działać... - problem z update do 2.81a

Zaczęty przez RamonaDział Offtopic

Odpowiedzi: 1
Wyświetleń: 1348
Ostatnia wiadomość 11.01.2020 18:27:38
wysłana przez Piotr
Problem z kartą graficzną i startem Blendera

Zaczęty przez iwoneqDział Tender Blender

Odpowiedzi: 12
Wyświetleń: 3124
Ostatnia wiadomość 08.03.2020 23:12:42
wysłana przez alex
UNREAL ENGINE SHADING PROBLEM

Zaczęty przez GrzesMANDział Inne programy

Odpowiedzi: 2
Wyświetleń: 2774
Ostatnia wiadomość 24.08.2017 16:46:29
wysłana przez Wookie

* Zaloguj




* Losowy obrazek