Praca Miesiąca - guests

Memento Mori
Praca Miesiąca Styczeń-Kwiecień 2020
mrys

Autor Wątek: Problem ze znikającym ogniem  (Przeczytany 1895 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Kubik

  • Vertex
  • *
  • Wiadomości: 34
    • Zobacz profil
    • Osiągnięcia
Problem ze znikającym ogniem
« dnia: 20.04.2020 23:34:12 »
Cześć, pracuję nad symulacją ognia z silnika rakietowego i napotkałem pewien problem. Chcę aby płomień miał dużą prędkość, charakterystyczną dla silników tego typu, więc zwiększyłem parametr initial velocity normal na 5. Problem w tym, że im ta prędkość jest większa tym ogień szybciej....znika. Wygląda jakby ogień był wyemitowany tylko na początku i "rozdmuchany": https://imgur.com/yjJg7mO
Dlaczego tak się dzieje? Jak mogę emitować ten ogień z obiektu cały czas, ale ze zwiększoną prędkością?
 

Offline Piotr

Odp: Problem ze znikającym ogniem
« Odpowiedź #1 dnia: 21.04.2020 09:42:20 »
Używasz najnowszego blendera, czy 2.7x?

W każdym razie w B2.82, są 3 rzeczy, które wpływają na czas spalania:
1. W ustawieniach Domain zmniejszenie parametru Fire >  Reaction speed o połowę wydłuża czas spalania dla szybko wydmuchiwanego płomienia.
2. W ustawieniach Flow, aby ogień ciągle się wydobywał, ustawiłem Flow behavior na Inflow.
3. Żeby płomień nie zdmuchnął sam siebie można jeszcze dla Flow zwiększyć parametr Fuel.
 

Offline Kubik

  • Vertex
  • *
  • Wiadomości: 34
    • Zobacz profil
    • Osiągnięcia
Odp: Problem ze znikającym ogniem
« Odpowiedź #2 dnia: 21.04.2020 10:29:45 »
Tak, zapomniałem napisać, że pracuję na 2.82a. Reaction Speed mam tutaj już ustawione na 0.1, w ustawieniach Flow zachowanie również na Inflow.
Poeksperymentowałem teraz z tym parametrem Fuel o którym piszesz i choć nieco potrafi on spowolnić ten efekt rozwiewania ognia to jednak niewiele to pomaga :/

Tutaj Fuel ustawiłem na maksymalna wartość 10, a Initial Velocity pozostawiłem na 5:
https://www.youtube.com/watch?v=dRXIrHqq7lQ&feature=youtu.be
« Ostatnia zmiana: 21.04.2020 10:50:04 wysłana przez Kubik »
 

Offline Piotr

Odp: Problem ze znikającym ogniem
« Odpowiedź #3 dnia: 21.04.2020 11:01:44 »
A podeślij plik .blend z samym ogniem, może coś wymyślę wieczorem.
 

Offline Kubik

  • Vertex
  • *
  • Wiadomości: 34
    • Zobacz profil
    • Osiągnięcia
Odp: Problem ze znikającym ogniem
« Odpowiedź #4 dnia: 21.04.2020 11:10:11 »
 

Offline Piotr

Odp: Problem ze znikającym ogniem
« Odpowiedź #5 dnia: 22.04.2020 17:27:00 »
Wykombinowałem tyle, że gdy ogień wydobywa się z dużą szybkością, to potrafi sam siebie zdmuchnąć. Obejścia są 2:
a) zwiększyć ilość paliwa
b) na drodze płomienia ustawić zapalniki, które na nowo rozpalą zgaszone paliwo

W pliku rakieta_a.blend w ustawieniach kółka zwiększyłem Surface Emission (tak jak ilość paliwa, jest ograniczone do 10).
W pliku rakieta_b.blend pod rakietą dodałem mały emiter ognia, który zapala się, kiedy "oryginalny" płomień wygasa i podpala paliwo na nowo (w pięćdziesiątej klatce).
https://drive.google.com/open?id=14ZQ_nzSMNv34lXrDgvOOpy8DZfnKH3lu

Nic lepszego nie wymyśliłem, daj znać, czy pomogło to coś.
 
Użytkownicy, którzy podziękowali za ten post: Kubik

Offline Kubik

  • Vertex
  • *
  • Wiadomości: 34
    • Zobacz profil
    • Osiągnięcia
Odp: Problem ze znikającym ogniem
« Odpowiedź #6 dnia: 24.04.2020 23:25:04 »
Dzięki, pomysł z zapalnikiem całkiem ciekawy ;)
Pokombinowałem jeszcze trochę i udało mi się osiągnąć dobry efekt wyłączając Initial Velocity i zastępując je wiatrem: https://www.youtube.com/watch?v=4476TIXvizI&feature=youtu.be. Teraz pozostaje to dopracować, ale działa mniej więcej tak jak chciałem.
 

 

Problem ze swiatlem point light przy jednoczesnym uzywaniu HDRI

Zaczęty przez KrzysztofJDział Oświetlenie i rendering

Odpowiedzi: 6
Wyświetleń: 4538
Ostatnia wiadomość 24.04.2018 01:28:39
wysłana przez KrzysztofJ
Texture Coordinate Sterowanie przez Armature Pose Mode Problem

Zaczęty przez alien1983Dział Modelowanie

Odpowiedzi: 0
Wyświetleń: 1820
Ostatnia wiadomość 09.04.2020 19:10:17
wysłana przez alien1983
Sterownik AMD przestał działać... - problem z update do 2.81a

Zaczęty przez RamonaDział Offtopic

Odpowiedzi: 1
Wyświetleń: 1010
Ostatnia wiadomość 11.01.2020 18:27:38
wysłana przez Piotr
Problem z kartą graficzną i startem Blendera

Zaczęty przez iwoneqDział Tender Blender

Odpowiedzi: 12
Wyświetleń: 2194
Ostatnia wiadomość 08.03.2020 23:12:42
wysłana przez alex
UNREAL ENGINE SHADING PROBLEM

Zaczęty przez GrzesMANDział Inne programy

Odpowiedzi: 2
Wyświetleń: 2396
Ostatnia wiadomość 24.08.2017 16:46:29
wysłana przez Wookie

* Zaloguj




* Losowy obrazek