Autor Wątek: Utrata jakości po renderze  (Przeczytany 2577 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline hudson462

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Utrata jakości po renderze
« dnia: 16.08.2018 23:17:57 »
Cześć :) Na wstępie chciałbym zaznaczyć, że nie jestem profesjonalnym grafikiem i styczność z blenderem mam tylko od czasu do czasu (bardziej interesuję się muzyką, a blendera używam aby tworzyć proste animacje jako tło pod muzykę). Przechodząc do rzeczy- mam gotowy projekt w blenderze, w sumie już koło 100 klatek mam wyrenderowanych i ich jakość jest dla mnie akceptowalna. Problem pojawia się po wyrenderowaniu tych klatek do animacji bo powstają wtedy dziwne artefakty i trochę szumu. W sumie to na monitorze na którym zrobiłem projekt tej animacji to wszystko jest w miarę ok nawet po wyrenderowaniu do animacji, ale kiedy sprawdzam jakość na laptopie to wtedy pojawiają się te artefakty (a rozdzielczość na obu monitorach jest identyczna). Każda klatka jest wyrenderowana do png, a animacja jest złożona z tych png do bezstratnego formatu (tym większe moje zdziwienie, że pojawia się utrata jakości względem pojedynczych klatek). Nie sądzę żeby wina leżała po stronie niskiej ilości sampli bo mam je ustawione na 512. Podsyłam zdjęcia, może ktoś będzie w stanie pomóc. Nie do końca wiem jak nazwać te artefakty... może brak płynnego przechodzenia między kolorami... Trochę to przypomina góry na mapie xd
Na zdjęciach nienajlepiej to widać, ale nie wiem jak wam to lepiej pokazać.


« Ostatnia zmiana: 17.08.2018 00:25:08 wysłana przez hudson462 »
 

Offline Piotr

Odp: Utrata jakości po renderze
« Odpowiedź #1 dnia: 17.08.2018 09:19:11 »
Jeżeli były obrazy PNG i  bezstratny kodek, to może kwestia matrycy monitora?
1. Jaką masz matrycę na obu monitorach? TN, IPS, VA?
2. Możliwe, że program do odtwarzania filmu, nie wyświetla pełnego zakresu tonalnego kolorów. Normalnie piksele świecą z mocą od 0 do 255, ale odtwarzacze filmów często mają ograniczony zakres od 16 do 235, przez co przejścia miedzy kolorami mogą stracić płynność.
3. Jak monitor jest podłączony przez HDMI (nie wiem, jak to w laptopie sprawdzić), to zakres tonalny też może być ograniczony i trzeba zmienić ustawienie w opcjach karty graficznej.

Pewnie coś jeszcze może mieć wpływ.
 
Użytkownicy, którzy podziękowali za ten post: hudson462

Offline hudson462

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Odp: Utrata jakości po renderze
« Odpowiedź #2 dnia: 17.08.2018 11:05:59 »
Właśnie też myślałem nad tym, że stacjonarka na której robiłem projekt ma podpięty wyświetlacz o matrycy TN, a laptop ma IPS ;/ Może coś z projektem jest nie tak, może kolory mają za duże nasycenie- pewnie wy lepiej to ocenicie bo robicie w grafice na codzień.

Pierwsza klatka:



Animacja z 93 klatek:

https://www9.zippyshare.com/v/tQv2e8yE/file.html

Co do zakresu tonalnego to można go zawęzić w after effects? Jeśli tak to jakim efektem?
 

Offline Piotr

Odp: Utrata jakości po renderze
« Odpowiedź #3 dnia: 17.08.2018 18:23:37 »
1. Właśnie chodzi o to, aby nie zawężać zakresu tonalnego. Jak będzie zawężony, będzie ograniczona liczba kolorów, a wtedy płynne przejścia między nimi będą skokowe jak na screenie.
2. IPS powinien mieć lepsze kolory niż TN. Nie masz czasem na laptopie TN, a na drugim IPS?
3. Szum na ekranie z matrycą TN może brać się z tego, że ta matryca nie jest w stanie wyświetlić wszystkich kolorów i fejkuje używając ditheringu. Czyli niektóre pixele świecą jaśniej/ciemniej, aby z daleka dać wrażenie ładnych kolorów, a z bliska wyglądają jak szum. Tylko nie wiem, czy ta sztuczka jest dalej wykorzystywana na współczesnych sprzętach.
4. U siebie też widzę te skokowe przejścia na video na matrycy IPS. Nie tak wyraźnie jak na zdjęciu z laptopa.
5. Możesz zrobić jakiegoś screena z ustawieniami kompresji filmu?
6. Sorry za chaos, ale zmęczony po robocie jestem.
 
Użytkownicy, którzy podziękowali za ten post: hudson462

Offline hudson462

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Odp: Utrata jakości po renderze
« Odpowiedź #4 dnia: 17.08.2018 19:22:07 »
Dzięki za odpowiedź. Na laptopie na pewno mam IPS, a na stacjonarnym TN. I na TN właśnie nie mam szumu... Tylko IPS wariuje ;/ Zastanawiam się czy nie przesadziłem z nasyceniem kolorów w tej animacji, ale przecież png wyglądają ok- tylko animacja pozostawia wiele do życzenia.

EDYCJA: Zapomniałem o screenie ustawień kompresji, więc daję tutaj

« Ostatnia zmiana: 17.08.2018 23:14:43 wysłana przez hudson462 »
 

Offline Piotr

Odp: Utrata jakości po renderze
« Odpowiedź #5 dnia: 18.08.2018 09:54:28 »
Chyba jednak jest kompresja włączona. Jak masz listę OUTPUT QUALITY, to sprawdź, czy jest opcja LOSSLESS. Daj znać, jak wyszło.

Inna sprawa, że jak wrzucisz film na Youtube czy inne Vimeo, to cały obraz zostanie zmasakrowany ;)
 
Użytkownicy, którzy podziękowali za ten post: hudson462

Offline hudson462

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Odp: Utrata jakości po renderze
« Odpowiedź #6 dnia: 18.08.2018 10:35:35 »
Z loseless też próbowałem i efekt jest albo podobny albo taki sam. A co do wrzucania na YouTube to trochę lipa, bo skoro ta animacja wygląda marnie już przed uploadem to co będzie po...?

EDYCJA: A czy to ma znaczenie, że renderuje klatki do png 8bit zamiast 16bit?
« Ostatnia zmiana: 18.08.2018 15:15:12 wysłana przez hudson462 »
 

Offline hudson462

  • Vertex
  • *
  • Wiadomości: 5
    • Zobacz profil
    • Osiągnięcia
Odp: Utrata jakości po renderze
« Odpowiedź #7 dnia: 14.09.2018 20:24:31 »
Jakby kogoś interesował efekt końcowy lub lubi słuchać progressive house'u to łapcie:

 

Offline Zglif

  • Noob
  • Wiadomości: 3
    • Zobacz profil
    • Osiągnięcia
Odp: Utrata jakości po renderze
« Odpowiedź #8 dnia: 20.09.2018 18:11:46 »
A czy to ma znaczenie, że renderuje klatki do png 8bit zamiast 16bit?
Właśnie to jest przyczyną. Renderując w 8 bitach masz głębię w zakresie 0 - 255, a w 16 bitach 0 - 65535. Dlatego 8-bitowe gradienty wychodzą tak skokowo, bo po prostu jest zbyt mała ilość odcieni szarości i części wartości brakuje.
 

 


* Zaloguj




* Losowy obrazek